RAC down for personal files?

Anyone else having issues accessing personal clients? No problem for business clients but when I enter a SIN # I get nothing but an unending loop.

I just got access but I think they may be upgrading to their new interface. Good luck to us all.

All good here.

Definitely a new look since yesterday.

That’s all I get for a SIN # through “Represent a Client”

I’ve tried three different browsers and none will work for me. :frowning:

I haven’t had any trouble getting in but they sure have rearranged things on the individual side, that’ll take some getting used to…

I’m not having any problems. Perhaps clearing the “cookies” on your browser may work.

Just logged in. No issues, but haven’t looked at a file yet. Still trying to get an Authorization done!!

I did have time to check if we are yet able to change addresses on business accounts…but nope. Still can’t edit.

These IT / bureaucrats are hopeless.

I just got on, no problems, but I had rebooted my computer this AM, maybe that helped.

Pat Gamborg


1354 Fed Road

Bear River NS B0S 1B0


I’ve been having problems with business access since yesterday. Reboots have not been helping. I tend to get partway through a task, then it just sticks. Even today, no more than 20 minutes ago.

Logged in for a while. No problems. Can now check “Uncashed Cheques” for individual clients. Found two just in passing…totalling a little over $400.

Cleaner look in part. RepID now appears at the top of the screen during use. No ability to change addresses still though.

Doesn’t appear there are changes on the Corporation side yet.

Logged in Rep a client and Surprised to take a note of a new changes that the option for submitting documents is available for some clients and Option for submitting documents is not available for some client . This Option was previously available for all before the changes in the website of CRA.

I had an hour conversation with a CRA agent in the e-services department. They were to supposed to make changes to the CRA MyAccount services but it has unfortunately effected CRA Rep a client services.

The surprising part was that we found that the they’ve linked the Rep a Client services with your personal CRA account login details. Meaning if you had created login username and password specifically for the Rep a Client services, it will not work. You must use your personal CRA username and password and then login through the Rep a Client services. Sounds confusing :sweat_smile:

Not sure that is accurate:, or I’m not understanding. I just logged in using my RAC creds to my personal account directly. The only thing I needed to do was add a separate email address for notifications because I hadn’t done so yet.

I can access all this morning:-) Just went in and entered a SIN # and got in.
Thanks everyone!

When I access a client file through RAC it won’t let me upload information unless I have a security code!!! Was this change announced somewhere that I missed. When I try to get a security code it takes me to page that doesn’t seem to apply!

Any suggestions?

Things are a bit different but I have been doing everything I typically am able to do.

Everything I would say was a bit easier and straight forward before but it could be just my aversion to change.

Took a while to figure out how to upload a T2201.

1 Like

I noticed, too, that the submit documents system seems to have changed.

I have been experiencing intermittent issues with RAC for the last few days.

Display issues, page errors, spinning circle of death. Just wondering if it is something others are experiencing?

I’m getting issues today. I can log in and type in a SIN to see their overview. But everything in the overview is an error/warning message:

Seems odd. I’ve tried a couple different clients.