CRA browser update screen

In the last half hour, I’ve lost the ability to log into RAC. The page opens to a message about my browser needing to be updated. I have checked both browsers (chrome and firefox), as well as tried to log in on my phone. All my browsers are up to date.

Is this happening to anyone else?

Yes, me too. Can’t log in

Can’t get in either. Just did a windows update and still no access. Both Chrome and Edge are up to date. Does CRA know about this?

CRA site is down, i also unable to log in.

Well, I’m glad it isn’t just me anyway. I can stop trying to fix it. This is no big deal. I’m sure, like me, you all have time for this right now. :crazy_face:

Mine is down too. If it’s down for a while maybe we will get lucky and they will extend the deadline to Monday…

Did anyone else get this message yet??
Please note that the previous multi-factor authentication issue has been resolved. Thank you for your patience.
Select the service you would like to log in / register for.

Now, here’s the thing. Below that last message are 3 horizontal blocks, presumably for “My Account”, “My Business Account”, and “Represent a Client”.
But, they’re all blank. I called the 5525 number and the wait is over an hour. Anyone have a faster number?

I haven’t seen that one. The one I’m getting is this:

Represent a Client

If you are using an older browser that does not support the latest security standard, you will not be able to access CRA’s secure online services.

Same here. Can Efile though.

I’ve had both messages. Must be alternating between the two.

A friend at Block said they put out a eblast notifying. apparently AFR will work if you clear your browser between every connection

I cannot login either… the entire rep client seems to be down… I switched browers… oh my … so I though I was going to finish on time… eek

Same here - older browser message

Tried that … didn’t work for me

AFR doesn’t work for me. I cleared data and still got the same response. But, I can e-file, as long as I don’t care if I’m missing slips.

Same here. We are all locked out, my entire team!

USe the link on the page to report the crap out of this.

Also locked out. Totally not impressed. AFR also doesn’t work.
Tried multiple browsers. CRA MY Account works, but both My Business Account and Rep-A-Client are out due reflecting this outdated browser message.

Hmmm … could this be CRA’s underhanded way to force an extension on the deadline
ie: gives them an excuse to extend it whereas prior to this the upper management wouldn’t approve it?

I may get to finish early tonight.

Here is a work around. use this link to open R-A-C and leave it open. then start AFR from the software. it should open a new tab for download and leave the first RAC tab open.