TaxCycle | Products | Pricing | Training | Documentation | Support | News

Tax Cycle not launching

Anyone else have problems with this last update and Tax Cycle not launching? I ran the update last night and today I can’t run the program, even tried uninstalling it and reinstalling it, and of course support is closed!!!

Try using Windows Task manager (processes tab) and “end process” on TaxCycleService.
Then restart taxcycle program

I did that already it’s not showing as running

TaxcycleServe.exe *32 is always running

You may have to check your services and manually restart the service

And how would one do that :rofl:

I’m not overly tech savvy, if I’m given steps I can figure it out.

start / run / services.msc

Also Services is normally one of the tabs in the windows task manager that you said that you had already checked.
.
If TaxcycleServe.exe *32 is not present you may not have taxcycle installed properly on your computer

It’s not there. When I go into my program files and double click on TacCycleService.exe I get an error message that it cannot start service from the command line or a debugger blah blah blah

This is so frustrating i was just using the program last night.

I’ve tried everything, I’ve uninstalled the program, downloaded a new copy from the website and reinstalled it and it’s still not launching, even after installation when it says “finished” it doesn’t launch when it should. I’ve got like 30 returns to get done this weekend :sob:

I’ve reinstalled the last version before this update and it’s working again, definitely something with the March 5th update and Windows 10…

something probably got corrupted in the update process try updating again

You can try an go back and install the version prior to the update