TaxCycle | Products | Pricing | Training | Documentation | Support | News

T2 Version 3.2.25570.0


After installing today’s update, I cannot import a gifi file exported from Caseware into TaxCycle if I have included exported notes. It works fine if I do not include the notes in the export. The import was flawless prior to the update, so it appears something may have broken…



Thanks for this information. We will investigate and let you know what we find.

Best regards,

~ Cameron



Did you submit a crash report? If so, did it start with something like: Error : Trilogy.Extensibility.Messaging.MessageHandlerException Unable to Execute ‘IndexItemChanged’ (Target : ‘Trilogy.Forms.View.Index.IndexMapper’ Type : Trilogy.Forms.View.Index.IndexMapper).

If so I’ve found the problem and have fixed it for the next update… which will be next week with some more TaxPrep conversion and possibly the T3010…

Thanks for your help.

~ Cameron


@Cameron, It did not appear to be an unhandled error. I received an error message indicating that the import could not be done (it did clear all values first). There was no option to submit and error report.

I also looked at the logs and this is the message in the log relating to it:

SourceTrace Verbose: 0 : Executing GIFI service data import
SourceTrace Verbose: 0 : Importing Gifi data from CaseWare International Inc. ‘’ into (my client’s name)'s return
SourceTrace Verbose: 0 : PublishDispatch finished in 897 ms



Thanks – I think I found the problem. I can send you a build with the change… would you mind verifying that I’ve fixed it??

~ Cameron


@Cameron, That would be great. I will load it and let you know if it works.



Perhaps we should kill two birds with one stone… I’ll ask Andrew to look at the TaxPrep 2013 T1 indexing first thing in the morning, and then we’ll try to address both issues at once, which could save us both some time. If you disagree, let me know.

~ Cameron


@Cameron, your plan sounds good to me. Thanks.