TaxCycle | Products | Pricing | Training | Documentation | Support | News

Client manager server not responding after 7.0.32184.0 update


#1

Is anyone else having issues with their client manager server not responding subsequent to this update?

There is no error message suggesting the client manager server is inaccessible, and nothing returned indicating searches are coming back with zero hits. Just a flash of the thinking circle and then blank when we try to run a search on any PC with the update.

I’ve tried restarting the server a few times, and rebooting the machine it runs on with no luck.


#2

Confirmed.

Server Essential 2012 R2 - Taxcycle 7.0.32184.0 Installed for Taxcycle services. Restarted server and reindexed. Searches in Client manager on server works.

Workstation: Windows 10 Pro. Taxcycle installed, Taxcycle servcies not running. Running client searches in client manager fails.

Feature worked fine in previous release.


#3

This is a little worrying. Post update, a new Client Manager (TaxCycleService.exe) is installed. Is it possible that one of the following has occurred?

  1. Has the TaxCycleService.exe has been quarantined by anti-virus software?
  2. The existing firewall rules no longer apply to the new TaxCycleService.exe making the server appear inaccessible to your workstations.
  3. Is the server discoverable from a workstation? Open TaxCycle / Options / Client Manager then click on Discover servers on your network.

Rick – does Client Manager respond on the server, or is it just the workstations like Cory?


#4

Hi Andrew,

  1. No anti-virus quarantine’s have occurred.
  2. Haven’t had time to check
  3. Yes, it’s discoverable on the network. The other PCs actually still indicate that they are connected to the server despite nothing being returned for searches

I have our “server” running on my workstation, which is a windows 10 PC, so similar results to Cory. There is no response when I search on my PC or others.


#5

We are in exactly the same situation as Cory. Running RDS. On the client side it says we are connected to the client manager, and we can Discover it.

Client manager works fine when logged in on the administrator account.


#6

When I looked at the log files for the client manager, it said it had dealt with the firewalls properly.


#7

Mine is working fine…


#8

Having the same issues. Sole practitioner - so my Client Manager server is installed locally on my work computer. Restart, Indexing, etc did nothing. I have no clients showing in my client manager but TaxCycle says I’m connected to my Client Manager Server. Also running Windows 10.

Checked Antivirus - TaxCycleService was automatically allowed - not blocked.


#9

try opening the client manager and manually restarting it after reboot of computer


#10

Usually I am the person who has Client Manager issues after an update, but my Client Manager is working fine with the 7.0.32184.0 update.

My Client Manager is installed on a Synology Network Attached Storage device and I find that I need to reboot my computer after every Taxcycle update or else the Client Manager will not connect after an update. I installed the latest update, rebooted computer and Client Manager works fine on my system.


#11

Thanks for the suggestion - I gave it a shot (and this approach has resolved issues I’ve had in the past), but it isn’t working in this case for some reason.

I also allowed TaxCycle through the Windows firewall again to be sure that wasn’t the problem.

I tried to go to my next step of re-indexing and then restarting the client manager server, but it looks like I can’t re-index at the moment. Despite all the usual directories being selected for monitoring above, when I go to index it returns this immediatley:

image

@Andrew, not sure if that provides any further clues as to what might be causing this.


#12

Double check your monitored folders and reset them up if required. The program says it is scanning 0 folders

edit, I just updated my server and other than having to manually restart the client manager, it is working fine as far as I can see.


#13

For the record, we do not have any issues with scanning the monitored files, and reviewing the CM log.

Reviewing the log this morning I see the following:
Error : System.OutOfMemoryException Exception of type ‘System.OutOfMemoryException’ was thrown.
Source : mscorlib
Details : at System.Threading.Thread.StartInternal(IPrincipal principal, StackCrawlMark& stackMark)
at System.Threading.Thread.Start(StackCrawlMark& stackMark)
at System.Threading.Thread.Start(Object parameter)
at Trilogy.IO.MonitoredPath.<>c__DisplayClass72_0.b__0(Object sender, ElapsedEventArgs args)

I then restarted the CM service. The out of memory exception went away, but still cannot use the client manager when logged on to the RDS as users, only when logged on administrator.


#14

For the server to return 0 folders, it can’t read the supplied list of monitored folders. This is usually a read permissions issue on those folders. Had you previously set up your Client Manager to run under a different user account? The servers log file should reveal what the issue is.

Did you run the full install (TaxCycleSetup.exe) or use Auto-update to update TaxCycle?


#15

From a workstation, is one of the Client Manager views selected (one should be blue),


#16

Well that last one solves the problem pretty quickly :slight_smile:

Any idea why a default view would not be selected?


#17

It should have automatically defaulted for you. I will need to figure out why it didn’t!


#18

I initially applied the update, but just reinstalled from the latest full installation package with no change.

Clicking on a view seemed to solve half our problem as well – the searches are running correctly now but when I tried to re-index it was showing the same issue. In the log files it’s saying the locations aren’t accessible, so just to be safe I ran through the client manager server setup to make sure the service was running under my network user name, which is an admin on our domain. It looks like it was re-set at some point to be using my local name on my machine. After re-setting it to my network username and rebooting it appears to have fixed the problem.

So for us it looks like there were two issues: the view not selecting to a default on searches, and the TaxCycle Shared Services user getting re-set to local. To be fair I haven’t tried to re-index since a win 10 anniversary update recently got installed, so that may have been the culprit regarding the shared services user issue.


#19

Well that solved my issue! None of them were blue. As soon as I clicked one of the, my client list showed up!


#20

One of the ‘views’ was not automatically selected after update either