TaxCycle | Products | Pricing | Training | Documentation | Support | News

A T2 Auto-fill system error has occurred that has prevented any tax data

I have been getting this message intermittently on AFR. Has anyone else had this?

Seems like the transmission is going well, but then on the last stage the AFR ‘flakes out’…

Is this a CRA problem or a Taxcycle problem?

You are not alone but I have no idea whether it is a CRA or TaxCycle problem (although I’d bet on CRA).

I have definitely seen a slow down in accessing Auto-Fill. CRA website slow to refresh and getting numerous time-outs.

Would you have happened to see a code 503 beside the test you posted?
The T2 AFR guide CRA provided to us mentions that it is a system error and to try again later.

I sent the team we deal with a note asking them if they were aware of any issues with their servers.

please find pic attached… no error code…

The IT area of CRA replied that they had a hiccup around 10:13 Eastern this morning that only lasted a couple minutes. They see plenty of successful downloads since that time.
Let me know if you are still seeing this error message. If you could, the exact time of the error would be useful.

just did one again that was rejected.

The nature of these rejections are specific accounts, that will not download in numerous attempts, while other accounts will download sucessfully.

3:37 pm mdt

3:57 mst did one that did download…

I will provide some more detail. When TaxCycle makes the tax data download request, the CRA sends back one of the following 4 codes:

  1. Found (data found)
  2. No data (no tax data available to download)
  3. Found_Incomplete (tax data found but issues encountered)
  4. Error (an error)

We think that the issue is to do with code 4 (Error). But unfortunately, CRA does not send back any specific error code number. We have internally tried to reproduce this issue in the T2 AFR test site but so far have not been successful.

If anyone is willing (comfortable) to share your Represent-A-Client id/pw and the T2 file with us, we can try this on our side and see what error is coming back to us. If you are willing to help, let me know (PM me, call us).

Thank you!

Steven

was just in conversation with Allan Burns regarding this, and have sent a file to your info ecourier mailbox

I did auto fill 1 exact file, once with TaxCycle, and once with another software.
TaxCycle did not fill the financial Data (GIFI 100 and 125), the other software did fill the data (GIFI 100 and 125)
I believe Taxcycle, should take a look at that.

I am willing to share the data, and can demonstrate that to Taxcycle if they wish!

@BertMulderCGA Thank you. Unfortunately, we are still looking for help to reproduce the issue in the CRA production site. We have a theory as to why this might be happening but no way to validate it through testing.

@imad We hope to add a feature to create a prior year T2 return from a downloaded .cor. Then, one can easily carry forward or carry forward refresh not only to get prior year GIFi but also all closing tax balances such as UCC, reserves, losses etc. This is on our todo list.

Steven

We plan to release TaxCycle this week with a fix that will help you deal this issue. So, please watch for it and make sure you read the release notes which will explain how to deal with this issue. Thank you everyone that has assisted us with identifying the issue.

Steven

will that new release includes the T2 rollover from Visual Tax?
Regards
Imad

Yes Imad it will

An update. I notified the CRA about this T2 AFR issue. As suspected, this is an issue on their end and they are looking into fixing this.

In the future, if you do get this error message, please phone us or email us to let us know so we can notify the CRA. Please keep the timestamp (of when the T2 AFR was performed) on hand and provide the BN of the corporation to us so we can provide this information to the CRA for them to investigate. Again, thank you everyone for your help.

Steven

I suppose it’s kind of late now, but yes - I have seen this a few times. The last time, about a month ago, I phoned TaxCycle directly (sorry - was too busy to post here on the forum). I spoke with Randy, who suggested it might be a corrupt file or data packet from CRA. After a few tries, I was able to get the AFR data imported by de-selecting one of the check boxes (see below).

Over the last week or so, Randy has been in contact several times to get my RAC credentials, so that Trilogy staff (I’m guessing Steven?) could do testing. The update earlier this week now gives TaxCycle some functionality to help figure out which check box to deselect.

@Nezzer Really appreciate your assitance. For information on how to correct the errors, please refer to the release notes on T2 Auto-fill.
https://www.taxcycle.com/News/TaxCycle-version-82356790#t2afr

I’m still getting this AFR download issue from CRA. Installed latest TaxC patch this morning. This is what I received.


Tried to follow steps in release notes, but it doesn’t give me the option to “use download from XX minutes ago” and none of the 4 issues are noted?
I guess just have to wait and see if CRA figures out their issue?

Kevin

@kevin.mcleod The CRA informed me just now that this issue has been resolved today (they were busy testing from the time it was first reported by us). So, give it a try and see if you can complete T2 Auto-fill without getting this error message.

Steven