TaxCycle | Products | Pricing | Training | Documentation | Support | News

T2 AFR postal codes don't match?

Sometimes when I download the T2 AFR data, Tax Cycle displays warnings about address details. I can’t figure out what the problem is with the postal codes - I have typed them into the Info page without a space, and the AFR data seems to match. Why is it still complaining?
Info:

AFR:

For the first 12 months of using corporate AFR I had the odd issue pop up like you have described. Sometimes even a comma in the address the CRA had on file would cause the software to yell ow at you. Using corporate AFR for the last year has helped me to correct some spelling and other errors that CRA had on file for various addresses. I would perform the initial AFR and if the CRA’s data was incorrect I would log into Represent a Client, do a full address check on all of the accounts (RC, RP, RT, RZ) and overhaul any incorrect data the CRA had on file. Once I did this I would re-AFR the file to make sure everything imported fine.

I think I remember having issues with the Postal Code and can’t remember whether it was actually the postal code causing the flag or anything mis-matched in the address that would trigger the flag on the postal code field. In any event, if I felt the CRA data was actually correct I would just click on the “Use address from T2 Auto-fill” and the yellow diagnostic would go away. I thought this may even have been caused by ghosts left over from the Profile T2 conversion I did a few years back. It could even be that your addresses are using capitals and small letters and the CRA uses capitals only.

As for the “care of” if you want to use ANR Accounting instead of Nelson Selinger then you should log into into Represent a Client and change it there or else you will get this same diagnostic message every year when you use AFR.

@Nezzer This appears to me that the review message is noticing the difference in the postal code format. In the AFR data, the postal code has no space after the first 3 characters. I am not 100% sure but I think that is what it is. Would you be able to send me the file using ecourier? Make it to my attention and I will have a look with Andrew in the office. Thanks!

Steven

@snoplowguy
Thanks, Wayne. I’ve already updated the “Care of” field via RAC. But, when I click the “Use address from T2 Auto-fill” nothing happens. It’s as if Tax Cycle is unable to use the AFR postal code.

@Steven
Will do. Thanks.

I know Steven is working on it, but try deleting the Postal Code you have on the info screen then see if you can click the Use address from Autofill.

@Nezzer
Thanks for the file. As expected, the issue is to do with the postal code format.
The preparer postal code as entered in Options contains a space and that space is somehow being entered into the preparer postal code field (No, you won’t be able to tell by looking at it) in the Engagement form. Then, the space is included in the preparer postal code field in Info. So, we will need to look at this. We don’t have a solution at the moment but we are looking at it.

For now, to resolve this, go to the Engagement form, in the Contact person/Firm representative section, delete the Postal code/Zip code and manually retype it in. This should remove the mismatch review message. Thanks!

1 Like

@Steven
Aha! Thanks. That works. I have updated it in Options as well, so it won’t propagate further.
Just a suggestion - since the forms (like “Info”) don’t allow more than 6 characters for the postal code, maybe that field in Options can be set the same?

@Nezzer
Yes, ideally, we would add a postal code mask to options but we have not figured out a way to do this. So, we will have to investigate further.