Logging into the CRA

I hope this question is allowed since it is not directly related to TaxCycle. I have tried getting ahold of the CRA but can not get through to anyone who knows the answer to my question.

Does anyone know if the CRA blocks IP addresses?

About 1 month ago we switched to an Azure virtual desktop system. For the first few weeks all users could access the CRA represent a client using either Chrome or Edge. Then all of a sudden the users start getting error message “ERROR - CER.018. The username and/or password you entered are not correct”.

However, using the sign-in partner option still works for edge and chrome.

We did discover that Firefox will still work for signing in with username and password option. An IT person told me that this is probably because Firefox uses a VPN in the background and is masking our IP. So, I setup a VPN and connected to a server in Toronto and tried logging in again with Chrome and Edge and it worked.

So, I feel somewhat confident that it is an issue with our IP but not sure if it is the CRA blocking it and if so how to fix it.

Any suggestions would be appreciated.


Funny enough last week I could no longer log in to cra with edge… I have standalone computer… no networks

Works with Chrome… so switched to Chrome

Can still login to service canada with Edge

Not ideal situation but…

I am in New Brunswick, covid lockdown in my area and certain unions on strike…so now I am also teaching my child in Grade 2 as no in class school and there is no real ~online for this age group

Picking my battles…lol

Rachel Parlee

Our local sessions still work fine for all browsers but our printers, etc, etc are all setup on the remote session and that is were we need to login in from.

I confirmed that the version number and all the security settings for Chrome and Edge where the same between the local and remote sessions, and they are - the only thing that would be different would be the IP address as the remote session would show the IP address assigned at the data center.

Just tried from my Azure server - no problems at all. Suspect that you have a cookie issue more likely than an IP issue? Clear cache etc and retry?

1 Like

Yes, cleared the cache, etc, etc. None of that worked.

We are going to try and get a new IP issued for that machine and see it that works.

I did finally talk to someone at the helpdesk and they said that error message also appears when the Captcha can’t load because something it blocking it. However, right now we have the webfilter,etc, turned right off as part of our trouble shooting process so I know that isn’t the issue.