Locked out of AFR (due to Internet Service Provider)

I have been working with Taxcycle and AFR all day. Tonight my system took the update 6.1.31252.0 which seemed to install fine.

Unfortunately, after taking the update, whenever I Start AFR I get the AFR screen that shows the clients with check marks beside them, but when I hit “next” it goes to “Initiating” but never gets any further than that. I just sit there watching the little blue balls chase each other beside “Initiating”. I have tried different browsers (Firefox, Chrome) with no different results. After about 2 minutes it times out “Taxcycle was unable to complete the download. Taxcycle did not receive a valid response from the CRA because of an unexpected transmission error”.

Once I hit cancel and go back to the main Taxcyle screen the software has gone into almost like a “hard crash” state where nothing works for about a minute, can’t even close the program. After about a minute the software starts functioning again (except for AFR).

I have tried rebooting my computer, no improvement.

I can still use AFR if I load Profile T1 software, so it seems the AFR system is not down.

Is there an easy way to roll back to the previous version, so that I can get AFR functionality again?
I have done everything I can do from my end. I even tried bum starting it by having “Represent a Client” open and logged in with Firefox prior to initiating AFR but it seems Taxcycle can’t even open up a browser window.

32 bit Windows 7 with Taxcycle 6.1.31252.0

Has worked flawlessly for me after update. Hope you resolve it soon. I know the frustration you are feeling. I think I would rather lose a limb than a fully functioning computer. :grinning:

for rolling back, I think your only option is to download the previous version from the Taxcycle website. I have my system set so that updates do not load automatically, but are network controlled. Looked at the release notes, and decided to pass on this one…

Thanks guys. I took the update via the automatic “check for updates” dialog on the main Taxcycle GUI. I am downloading the full version now and will try a complete installation of 6.1.31252.0 and see if it changes things. If not, I am also downloading 6.31228.0 and will try to reinstall that version, which is what I was running before the AFR stopped functioning.

Has work flawlessly for me I updated in between clients tonight .
just down load the file and reinstall it maybe uninstall and reinstall.

You can download the 3 previous versions from the bottom of the download page.

Hopefully you have some time tomorrow to help us troubleshoot this one.

Installing the full version did not work and installing the previous version did not fix things. AFR no longer seems to initiate the browser.
I did not do an “uninstall” prior to installing either of these full versions.
Can I hurt anything by doing an “uninstall”? meaning… will I lose anything whatsoever?

You will not lose anything by uninstalling.

[quote=“Cameron, post:6, topic:1132”]
Hopefully you have some time tomorrow to help us troubleshoot this one.[/quote]

… looks like I will definitely need to have some time tomorrow… and then find a whole pile from somewhere once I get back up and running. Taxcycle AFR seems to be good and broke for me now. :confused:

  • Complete uninstall of Taxcycle, reinstalled 6.1.31252.0 - AFR will not connect with any browser

  • Complete uninstall of Taxcycle, reinstalled 6.1.31228.0 - AFR will not connect with any browser

  • System Restore of the Windows Registry back to February 28th, which shows a roll back of Taxcycle to version 6.1.31181.0 - AFR will not connect with any browser. It’s been a long time since I came across a problem that a “System Restore” wouldn’t fix.

  • Logged out of main Windows user and logged in as another user. Opened up Taxcycle, - AFR will not connect with any browser.

In every single case, the AFR screen opens, it says “Initiating” but doesn’t get any further. It will not open up a browser window. If I hit cancel, Taxcycle completely freezes up for about 45 seconds (nothing works). After 45 seconds Taxcycle thaws, and works fine again (except for AFR not working). Once again, it was working fine all day, and the only change to my computer was the automatic download and then the installation of 6.1.31252.0.

I can still use the “internet file slips” service in the T4, T5, T5018 modules without any problem, I can click on “Evergreen” or “Represent a Client” and Taxcycle properly opens up the browser to the proper website. My communication problem just seems to be with AFR.

To me, it feels like communication has been completely lost between the AFR routine and the web browser in that it won’t even open up the browser.


Two things to check before I go to bed:


If these two things don’t help, please send us a log file. To minimize the clutter, go to your log folder and delete all the log files. Then, try AFR. There should be only 1 file in your log folder. Send us that, please.

~ Cameron

No problem with AFR with Chrome since latest update. If I remember correctly, last fall, Taxcycle mentioned that 2016 edition was designed to work primarily with Windows 10.

I think I have tracked it down to being something to do with not being able to get network time for a time stamp. Somehow internet time is no longer working on any of our machines.


I was just speaking to our AFR expert and that’s what he hypothesized. The log files might help us out, if you’re able to provide those.

TaxCycle will try to get the time from up to 3 different time servers. Can you check to see if maybe your anti-virus software is blocking those requests?

~ Cameron

Hi Cameron, I sent the log files via e-courier about an hour ago.

Nothing is being blocked from here. I have troubleshot this likely to be a time server issue. What is a real mystery is that none of the Microsoft computers in the office (Windows 7 or Windows 10) will sync up with Windows internet time (on any of the servers) as using our ISP. I can get an Apple Macbook to time sync, but presumably it uses different ports or a different system. If I use an iphone as a personal hotspot I can get the internet time servers to sync. I have tried bypassing the router with our regular internet connection but still no go.

On the phone with the ISP for about an hour this morning… they are of no real use. They claim that no ports are blocked and if we have internet service everything is working fine… :slight_smile:

I will phone Taxcycle and see if they might have any ideas.

About half our ago someone higher up the food chain at our ISP phones and sheepishly concedes this is likely a problem on their end. They did some tests, and I did some calling around to some of our clients using the same ISP and it seems nobody is able to sync their computers with internet time. Of course, they can’t say what the resolution is at this stage… so my AFR is still down.

Hey @Cameron if you guys have been working on that log file at all you may as well close the ticket, and I really appreciate your efforts. It seems this likely isn’t anything you’re going to be able to solve from your end… just the timing of another issue that, once again, happened to coincide with a Taxcycle update.

Status Update:
Our ISP (essentially Rogers) have become aware that as of yesterday some of their customers are unable to sync their computers with “Windows Internet Time”. The reply I received from the “Elevated Support Team” is this issue is basically a minor inconvenience, and their priority would be escalated if we were without internet service. As it sits, this issue is low priority and they will get around to dealing with the issue in due course. The CSR didn’t seem to believe that we had software that needed reliable access to an internet time server in order to operate properly.

Of course he was different than the first guy who had me go to google.com and type “What time is it” in the search bar then compare it to the time on my computer task bar. When I told him both times matched his response was he didn’t see a problem.

I have tested and confirmed that I can connect to AFR using my iphone as a personal hotspot if I shut my network connection down. This means the non responsive AFR is not a Taxcycle issue.

Anyway, unless there is some way or setting that will make the AFR system work using the computer’s internal time for a time stamp instead of internet time service I guess I am out of the AFR game for the forseeable future. I can get AFR to work in Profile T1 software , so they must use something completely different. Unfortunately, their AFR interface is so poor that I’d rather punch every slip in by hand.

Murphy’s law is one thing… but I’m beginning to think Murphy actually lives at my place. :confused:


Thanks for this information. We did spend some time trying to improve TaxCycle’s response when the internet is down… as of the next release it should not hang when your ISP is not cooperating. We should now fail over to the time on your computer, so it might now work when your timeserver doesn’t.

You mentioned in an earlier post that ProFile’s AFR was working even though your timeserver was unavailable. This is because ProFile requests information from CRA through their own server, and then forwards that information to you.

TaxCycle doesn’t do that, which means that your timeserver has to work…

~ Cameron

1 Like