TaxCycle | Products | Pricing | Training | Documentation | Support | News

Auto-update is not installed

My version still shows 9.2.39956.0 ( taxcycle), 9.036933.0 ( DoxCycle), The software can find the update version, but when I click the gear button to install, it is just closed the app, and then open again, showing the same old version, and the new update is available.

I tried the options:\auto-update\rush or custom, no different, keep open the version 9.2.39956.0, it can’t auto-update. even if I closed the app, it shows a message: Update"10.0.41387.0" is available, I click install update, the app was just closed, but not proceed the installation.

Even I tried to manual update then new version starting from 9.2.40541.0 , it was still not updated.

I tried to uninstall the old version, under control panel\TaxCycle ( it shows version 8.134887.0), I click uninstall, first time it shows it can’t be found ( I forgot to copy the error message), and I tried to uninstall it again, it shows " an error occurred while trying to uninstall TaxCycle. it may have already been uninstalled. Would you like to remove TaxCycle from the Programs and features list?" even I choose " Yes" it still under control panel list.

I tried to just using the newest TaxCycle setup.exe file, it shows
" this program found an existing TaxCycle installation on this computer. click update to install this new version, after I click the update, when it shows installation complete. and launch TaxCycle, it shows still version 9.2.39956.0.

Do I miss something to update properly? any thought will be great appreciated.

Contact taxcycle support directly may be your best option.

Contact Us | TaxCycle

Oddly enough, I found the same thing y’day…I was looking to do some planning on the 2020 module (which I’d previously seen) and…couldn’t find it! I sent a note off to support and then saw “refresh licenses”…which I did and it immediately updated.

I thought that was automatic, but I guess not? (Monthly payer, auto-renewing license.)

I just received that same message
image.png

I had the same thing. Rebooted and did the auto update and it worked

Download the latest version. Reboot your computer and then run the download. It will update your installation.