TaxCycle | Products | Pricing | Training | Documentation | Support | News

T2 1135 Filing

I am just about to Efile a T2 that has an T1135. There isn’t a separate option to file the T1135 but I have selected that the company is subject to the foreign filing requirements.

They are over the $100K limit and I just am wondering if it gets filed at the same time or if I still need to paper file. I was under the impression that we can efile corporate T1135

There just isn’t any indication on the Transmit screen to file the T1135 and I want to make sure it gets filed.

Thanks
Michelle

What version are you using?

I don’t have that version and Taxcycle isn’t currently suggesting an upgrade. I will upgrade and see if that helps.

Thanks for the info!!

How to get this update
This release is currently only available as a full download from our website. We will release an automatic update in a few days.

I have installed the latest version but still don’t get the option to efile the T1135. I have contacted support but just wondering if anyone else has experienced this problem and may know the fix.

Did you click the box that says they have foreign investments? I was able to file a couple of weeks ago.

1 Like

Yes I did. I’ve checked and double checked everything I can think of. The only possible explanation I can come up with at this point is that it is because we filed the T2 with the older version. When we didn’t see the option to Efile the T1135, I did the update.

@jriley

What is the file extension of the T2 file? That will tell us what version of the T2 module you are using and we can figure out what next steps are.

Thanks…

~ Cameron

Thank you for this Cameron! It is .2015T2

@jriley

When the taxation year ends in 2014, we normally give you an option to convert at .2015T2 file to a .2016T2. But if you’ve already filed the T2 return, we no longer give you that option. The easiest way to solve this is:

  1. Make a back-up of your .2015T2 file, in case these instructions don’t work…
  2. Make sure the file is not open in TaxCycle
  3. Change the file extension to .2016T2
  4. Open the .2016T2 file in TaxCycle
  5. Check the transmit window

If this doesn’t work, you’ll need to call our office tomorrow, and someone smarter than me can help you sort it out…

Best,

~ Cameron

It seems like you are in fact plenty smart enough. The option is there now. Thank you again. Needless to say, this thing is due tomorrow and I am now very relieved.