TaxCycle | Products | Pricing | Training | Documentation | Support | News

Right click only working part-time

I’ve been noticing for about a week or two that the “right click” drop down menu only works part of the time. Most of the time the options are grayed out when I right click on a form. The “sorting” options (which are handy to use in the donation and medical schedules) generally don’t even show up when using “right click”. If I completely close out of TaxCycle and go back in, the “right click” option will work for a few times and then quit working again.

Is this problem specific to our office or has anyone else experienced this?

I’m sure this isn’t your problem, but sorting options will only appear if you click on a specified field so TaxCycle knows what to sort on. If you click on a blank spot on the form the sort options will not show…

Thanks @Cameron

I’ll attach a couple of screen shots to show what’s happening here.

This screen shot is of the donation schedule when I right click on the description field to sort them by charity. As you can see the option to sort doesn’t show up and the printing options are grayed out.

Right%20click%20-%20Donation%20Schedule

This screen shot shows the box which comes up when I right click to try to print a form or open the prior year tax return. As you can see the options which show up are grayed out so that we can’t select any of the options.

Right%20click%20-%20Sample%201

Now if I close out of TaxCycle completely and open up the file again, the right click will work once or twice and then it goes back to be grayed out again.

This screen shot shows the options which generally show up when you right click on a form. I just opened up my first file in TaxCycle so this is showing correctly now.

Right%20click%20-%20Sample%202

This screen shot shows the box which comes up when I right click on a specified field for TaxCycle to sort. Since I just closed out of TaxCycle completely and opened up the file it’s showing all the options. However, as soon as I start entering more information on different forms the right click options gray out again.

I hope this helps clarify the problem which we’re having.

The most helpful thing would be to describe the steps that you’re doing that make the right click context menu stop working. I’ll send this to our QA team to try as well, but if you can figure out the steps I’ll be able to fix it.

~ Cameron

A quick example is:

When I first open TaxCycle, I go to the Client Manager, select a T1 file to open for 2017. I run the AFR, enter the pension slips, verify the data with the client and then open the T183 for the client to sign. Right click on the T183 to print and the options don’t work. The links in the quick access toolbar work but not the right click menu.

It doesn’t seem to just be the right click menu which is doing this. I’ve noticed when I’ve tried to delete an old T4 slip for example which isn’t being used anymore the “Delete Slip” option and the other two options aren’t clickable.

Delete%20slip

When I’m done working on a file, I’ll close the file and open another file through client manager. I’m not actually completely closing out of TaxCycle and opening it up again. If I completely close out of TaxCycle and start the software again, these options will sometimes work for a few minutes and then quit working again. I haven’t timed how long I’m working to see if there’s a set time after I’m in the file that these options quit working.

Jennette –

We are not able to reproduce this behaviour. I’m not sure what else to suggest, but you could try updating or repairing the version of dotNet that is on your computer. Maybe something with your install has been messed up.

If you have any more clues, we’ll continue our investigation. Blair tried for about two hours, but right click always worked as it should.

~ Cameron

I have also been having that exact issue; initially thought I was missing a step when I tried to sort donations alphabetically. My solution so far has been to log out of both the client file & Taxcycle itself and then log back in.Thus far, that seems to have worked.
I thought it was my PC wimping out, but wasn’t convinced. Good to hear I’m not going bonkers (more than usual!)

It appears to be a user issue on one of the local computers. We’ve tried logging on different computers with different user names to see if that makes any difference. So far it appears to just be affecting one user. The user is an admin on the local computer which is having this issue.

We tried opening up TaxCycle by right clicking and running TaxCycle as Administrator. It worked some of the time and some of the time it didn’t. We also tried uninstalling and reinstalling TaxCycle to see if that made any difference. I’ll check into the dotNet on the computer as well.

I haven’t tried the various tests you have, as I’m a one person office. It is acting up again this morning - closing out of TaxCycle & then re-opening has worked again (simply closing the client file & re-opening does not)
The F8 key allows me to add a tape or memo. Haven’t yet discovered a key that let’s me sort data entries.
Appreciate your input.

What we ended up doing was deleting the user profile on the specific computer. That didn’t solve the problem though.

We went on to the server and found that there were a few different old user folders for this one user and deleted those. We also deleted this specific users folder redirection folders.

After doing this the issue with TaxCycle appears to be fixed.

It was a problem that was specific to one computer and one user as other users could log on to the computer with no problem. This specific user could log on to other computers with no problem. I’m not sure exactly what the problem was, but this issue has now been solved at our office.

Thanks for this Jennette; glad to hear this has been resolved.

I don’t operate in a server environment, but will do some exploring on my PC using the tips you’ve provided.

Best regards,

Garfield Cressman