OAS bumped up in year of death?

I haven’t noticed this before - in the year of death, the taxpayer must pay tax on the expected full year OAS amount, rather than the ACTUAL amount of OAS they received? I can’t find a reference on the CRA website, or any website for that matter.

Not as far as I know. You only pay taxes on the amounts received. When did the client die?

That person died Nov 2022, and was not my client previously, so I don’t know if there is something specific to certain people. But, to confirm, I checked a T1 for a previous client who died in April 2022. I carried forward the return from 2021, and before I download AFR data, I get this message in TaxCycle:

I checked several terminal returns I prepared in prior years, and none of them exhibit this phenomenon. So, is it a TaxCycle bug or was it something legislated to start in 2022?

Must be a bug. i can only find that benefits stop after the month of death.

When an Old Age Security (OAS) and Canada Pension Plan (CPP) beneficiary dies, their benefits must be cancelled. Benefits are payable for the month in which the death occurs; benefits received after that will have to be repaid.

Actually there was an increase last year for those over 75 years of age and that is why some of our older clients will have a different amount.

If you are or will be 75 years old or older in June 2022, you will get an automatic 10% increase of your Old Age Security pension starting in July 2022. If you are turning 75 after July 1, 2022 you will receive the increase in the month following your 75th birthday.Jan 16, 2023

Wouldn’t that be reflected on the actual T4A OAS slip? In this case the slip shows $7,581 but TaxCycle bumps that up to $8,335. Also, strange that I can’t type in an amount for that box 18 - I have to override the value calculated by TaxCycle.

Do you have this checked off in your Options for New Files? If yes, that is why it is automatically calculated:


My dad’s slip shows correct and he’s 81

Aha! Yes, that was it! Thanks @darlene !
Not sure when setting got checked - I don’t remember ever noticing it, so I’m not sure if that’s always been the default? Yikes.