TaxCycle | Products | Pricing | Training | Documentation | Support | News

T2 Capital Loss Carryback

When I enter the amount of a current year capital loss on line 951, 952, or 953 to carry the loss back, I get a yellow warning “Total capital loss amounts carried back cannot exceed [amount available]”. I have entered the amount of the current year loss. If I enter $1 less than the current year loss the warning goes away. I think maybe the test needs to be if the total of the losses carried back is greater than amount H, not greater than or equal to amount H.

@Kevin The condition for that message is checking to see if the total amount on lines 951, 952 and 953 > line 210. I have a hunch that there may be some underlying decimals that might be causing this behaviour. Can you try something for me? On line 210 of S4, I suspect there is decimal in the background. Can you try manually re-typing in the amount on line 210 in S4 and see if the review message disappears? By manually re-typing in an amount as an override, this ensures that there is no decimal. If you send me the file, I can take a look and fix this easily.

Steven

Hi Steven. Yes, manually overriding line 210 on S4 makes the error message go away (but pops up another message). I’ve seen this in a couple other T2’s that I’ve prepared in the last few months so it’s not just this file. I guess the program needs to round the line 210 number to zero decimal places?

@kevin Likely, it is not the calc for line 210 but related to another calc.In our calc coding, if rounding was omitted by mistake, decimals can carry over to a bunch of fields. I fixed one recently in S6 where we multiply an amount by a % without rounding.

Thanks Steven.

Ha ha…the old “the individual amounts don’t actually add to the column total visually”. How often (too many times!!) have I seen this on F/S…

(Would be kind of fun if Excel had an “autoround” function. Just enable it for sheet or book and the results of all calculations would automatically round to x digits, as specified.)